Lobby bug--no auto start

View previous topic View next topic Go down

Lobby bug--no auto start

Post  RuffRidah on Fri Jan 11, 2013 7:30 pm

With full lobby of 8 people, it did not auto-start. I don't know if this is a one-time bug or not, but I'll see.

RuffRidah

Posts : 48
Join date : 2013-01-05

View user profile

Back to top Go down

Re: Lobby bug--no auto start

Post  rut on Sat Jan 12, 2013 1:18 am

Thanks for bringing this to my attention--I tested it out myself and you're right, it's not autostarting.

After doing some research, it turns out that having a 12 player game mode is the cause of the problem. When using an 8-player game variant, which is standard, the game does not recognize that several player slots are intentionally closed. It instead sees only 8 people in a game that could potentially hold 12 and therefore won't autostart.

I'm working on figuring out some workarounds for this. Worst case scenario, I might have to remove 12 player mode until this is patched out in order to avoid an afk host ruining the experience.

rut

rut
Admin

Posts : 167
Join date : 2012-11-18

View user profile http://stardodgeball.forumotion.com

Back to top Go down

Re: Lobby bug--no auto start

Post  RuffRidah on Sat Jan 12, 2013 11:24 am

I remember there was a solution for this in Star Strikers, but I do not know how it worked. The person who solved this is also taking a break. However, we did start by removing start locations for the extra players.

(We tried to add spec players on a separate team for private lobbies.)

RuffRidah

Posts : 48
Join date : 2013-01-05

View user profile

Back to top Go down

Re: Lobby bug--no auto start

Post  rut on Sat Jan 12, 2013 1:38 pm

I've gone ahead and removed the 12 player option so that the 8 player game will autostart, but I'm gonna experiment with ways to fix this issue. I'm thinking that I could make the 8 player mode's 9, 10, 11, and 12th players computers by default instead of making them type "none," and then disabling them when the game starts. My fear, though, is that it would make the lobby more confusing to players. Maybe I could make those last 4 appear on a third team to reduce confusion. We'll just have to see what looks and feels right.

Rut

rut
Admin

Posts : 167
Join date : 2012-11-18

View user profile http://stardodgeball.forumotion.com

Back to top Go down

Re: Lobby bug--no auto start

Post  Sponsored content Today at 3:32 am


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum